Jump to content
Genetry Solar Forums

24v input 110v 220vac output with charger board help !


Big BOB
 Share

Recommended Posts

Hello, My name is Bob and i would like to say hi to all you guys and girls out there. Now I have a problem with my 8000w power jack inverter. it has two boards that do not have lights on. I am a retired electronic tech. I have the equipment to do the repairs. All I need it the flow chart or schematics, or if thats not available. how the thing works as in where it starts and where it ends as in troubleshooting. EX: 24v input to power board, to transformer switched with power MosFets etc. How the alarm circuit senses the alarms and what each cards function is. Or other help to get me going. Thanks for the help and hope everyone is healthy wealthy and strong. From Big Bob

Link to comment
Share on other sites

Sorry @Big BOB, the initial post missed my alerts, and I didn't even see it until @Tim posted back...

On 3/15/2021 at 10:33 PM, Big BOB said:

All I need it the flow chart or schematics, or if thats not available.

We don't have any flow charts or usable schematics.  Even if we did, they would be the IP (intellectual property) of Power Jack, and they would be none to pleased if we publicly shared it.

 

On 3/15/2021 at 10:33 PM, Big BOB said:

How the alarm circuit senses the alarms and what each cards function is.

Let me just say it's sometimes a wonder that it even functions.  Boards/cards are quite intertwined in ways that don't make any sense--so there's no practical "flowchart" that even could be written.

In basis, all power comes to the "mainboard", which is nothing more than a MOSFET H-bridge connected to the transformer.  All MOSFET drive signals--and battery power--go to the control board via the ribbon cable.  From there...it's all over the place.

 

On 3/15/2021 at 10:33 PM, Big BOB said:

Now I have a problem with my 8000w power jack inverter. it has two boards that do not have lights on

Can you elaborate further?  What version Power Jack inverter?  (I'm assuming from your mention of "cards" that it's between Rev. 4.0 and 9.0.)  What boards aren't lighting?  What does the inverter do when you try to turn it on?  Lights?  Beeper?  Error?  Try to run at all?  What was the inverter doing when it stopped functioning?  Photos of the setup/internals and what's going on?

Link to comment
Share on other sites

  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...