Jump to content
Genetry Solar Forums

PJ 20K - Now it won't turn on.. [SOLVED]


Busky
 Share

Recommended Posts

So my 20K PJ inverter which was working last time I turned it on...  It's been a couple months

and I  decided to turn it on.  I get one beep and then a continuous beep.  This is both in powersavings mode and regular mode.

It seems like it briefly turns on as I can hear the hum for a little bit.  And if I hook a AC fan to it, it turn on briefly..

 

Any thoughts on what the one beep then a continuous beep?  There is no alarm light and no INV on light.

 

Ugh!

 

Jim

Link to comment
Share on other sites

What control board revision does your PJ have?

Have to say that the (lack of) diagnostic info on PJ inverters does make it very difficult to figure out what's amiss.

 

So you're saying that the front panel LEDs never light up (even a brief flash)?  Was briefly wondering if a front panel connector was unplugged--but on all the newer PJs, the connector with the power switch is also the same one that runs front panel LEDs.

...if your inverter has front panel "voltage adjust" knobs, I'm wondering if that connector is loose/dirty.  Or maybe the "voltage adjust" knob is at fault??

Link to comment
Share on other sites

12 minutes ago, Sid Genetry Solar said:

What control board revision does your PJ have?

IDK..  I'll have to look.  It's barely a year old.

Quote

So you're saying that the front panel LEDs never light up (even a brief flash)?  Was briefly wondering if a front panel connector was unplugged--but on all the newer PJs, the connector with the power switch is also the same one that runs front panel LEDs.

...if your inverter has front panel "voltage adjust" knobs, I'm wondering if that connector is loose/dirty.  Or maybe the "voltage adjust" knob is at fault??

No brief flash of lights.  At least not fast enough that my eye can catch it.  I played with the voltage knobs with no effect.  😞

I do have a couple green LEDs inside that come on when I apply battery voltage...

I can't find any pictures of the control board. I only have the AC out board that I replaced when I first got it due to shipping damage.

I'll rip it open tonight if I have time after kid duties and look for anything loose.  It wasn't really jostled around..  But you never know, I guess....

Thanks, Sid!!

 

Jim

Link to comment
Share on other sites

  • Sid Genetry Solar changed the title to PJ 20K - Now it won't turn on.. [SOLVED]
13 minutes ago, Sid Genetry Solar said:

Done 😉

Not sure if as the OP you have the ability, but long-click on the title to edit it.  Not the most intuitive, that's for sure.

Nope..  I guess it's an admin thing only! 🙂

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...